Задать вопрос
1 августа, 11:12

Известны длины сторон треугольника a, b, c. Написать программу, вычисляющую площадь этого треугольника (по формуле Герона). Выполнить программу для исходных данных a=3, b=4, c=5. Язык Паскаль.

+3
Ответы (1)
  1. 1 августа, 12:52
    0
    Uses crt;

    var a, b, c:integer;

    p:real;

    begin

    writeln ('Введите a') ; readln (a) ;

    writeln ('Введите b') ; readln (b) ;

    writeln ('Введите c') ; readln (c) ;

    p : = (a+b+c) / 2;

    / / √ (p· (p - a) · (p - b) · (p - c))

    writeln ('Площадь: ', sqrt (p * (p - a) * (p - b) * (p - c))) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известны длины сторон треугольника a, b, c. Написать программу, вычисляющую площадь этого треугольника (по формуле Герона). Выполнить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)