Задать вопрос
21 августа, 08:11

Составьте программу нахождения наименьшего общего кратного (НОК) двух чисел, используя формулу:

А * В = НОД (А, В) * НОК (А, В).

+2
Ответы (1)
  1. 21 августа, 10:29
    0
    var a, b, c, d, i, n : integer;

    procedure swap (a, b : integer; c, d : integer) ;

    begin

    if a>b then begin c:=a; d:=a; end

    else begin c:=b; d:=a; end;

    end;

    begin

    read (a, b) ;

    swap (a, b, a, b) ;

    for i:=1 to a do if (a mod i=0) and (b mod i=0) then c:=i;

    write (a*b/c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу нахождения наименьшего общего кратного (НОК) двух чисел, используя формулу: А * В = НОД (А, В) * НОК (А, В). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы