Задать вопрос
3 ноября, 12:13

Напишите программу вычисления наименьшего общего кратного следующих четырех чисел: 36 54 18 и 15. Используйте процедуру вычисления общего делителя двух чисел

+4
Ответы (1)
  1. 3 ноября, 14:03
    0
    Var

    A:array[1 ... 4] of integer;

    i, j, R, P:integer;

    function HOD (c, b:integer) : integer;

    begin

    while cb do

    if c>b

    then

    c:=c-b

    else

    b:=b-c;

    HOD:=c;

    end;

    function HOK (c, b, RR:integer) : integer;

    begin

    if ((c mod b=0) or (b mod c=0)) and ((c div b > 1) or (b div c > 1))

    then

    begin

    if c>b

    then

    HoK:=c

    else

    HOK:=b;

    end

    else

    HOK: = (c*b) div RR;

    end;

    begin

    A[1]:=36;

    A[2]:=54;

    A[3]:=18;

    A[4]:=15;

    P:=1;

    R:=HOD (A[1], A[2]) ;

    P:=HOK (A[1], A[2], R) ;

    for i:=3 to 4 do

    begin

    R:=HOD (R, A[i]) ;

    P:=HOK (P, A[i], R) ;

    end; writeln ('HOK = ', P) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу вычисления наименьшего общего кратного следующих четырех чисел: 36 54 18 и 15. Используйте процедуру вычисления общего ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Составить программу для нахождения наименьшего общего кратного четырех натуральных чисел: по формуле НОК (A, B) = (A*B) / НОД (A*B) (Определить процедуру, распознающую НОД двух чисел)
Ответы (1)
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров , в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Составить программу для нахождения наибольшего общего делителя четырёх натуральных чисел используя процедуру
Ответы (1)