Задать вопрос
17 января, 10:39

Составить программу для нахождения наименьшего общего кратного четырех натуральных чисел: по формуле НОК (A, B) = (A*B) / НОД (A*B)

(Определить процедуру, распознающую НОД двух чисел)

+1
Ответы (1)
  1. 17 января, 11:03
    0
    uses crt;

    var

    a, b, c, d:longint; {нахождение НОД 2 х чисел по Эвклиду}

    function NOD (m, n:longint) : longint;

    begin

    repeat i

    f abs (m) >abs (n) then m:=m mod n

    else n:=n mod m;

    until (m=0) or (n=0) ;

    NOD:=abs (m+n) ;

    end;

    begin clrscr;

    write ('a=') ; readln (a) ;

    write ('b=') ;

    readln (b) ;

    write ('c=') ;

    readln (c) ;

    write ('d=') ;

    readln (d) ;

    writeln;

    writeln ('NOD (a, b, c, d) = ', NOD (NOD (a, b), NOD (c, d))) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для нахождения наименьшего общего кратного четырех натуральных чисел: по формуле НОК (A, B) = (A*B) / НОД (A*B) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике