Задать вопрос
9 июня, 18:02

Составьте программу нахождения наибольшего общего делителя трёх чисел, используя следующую формулу:

НОД (A, B, C) = НОД (НОД (A, B), C).

Нужно на паскале

+4
Ответы (1)
  1. 9 июня, 19:23
    +1
    var

    a, b, c:integer;

    begin

    write ('a = ') ; readln (a) ;

    write ('b = ') ; readln (b) ;

    write ('c = ') ; readln (c) ;

    write ('НОД (', a, ', ', b, ', ', c, ') = ') ;

    while (a 0) and (b 0) do

    if a > = b then

    a : = a mod b

    else

    b : = b mod a;

    a : = a + b;

    while (c 0) and (a 0) do

    if a > = c then

    a : = a mod c

    else

    c : = c mod a;

    writeln (a + c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу нахождения наибольшего общего делителя трёх чисел, используя следующую формулу: НОД (A, B, C) = НОД (НОД (A, B), C). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы