Задать вопрос
31 октября, 16:32

На языке программирования Pascal создать программу нахождения наибольшего общего делителя (НОД)

+2
Ответы (1)
  1. 31 октября, 18:18
    0
    Алгоритм еквлида

    var x, y:integer;

    begin

    read (x) ; / / первое число

    read (y) ; / / второе число

    while ((x-y) >0) or ((y-x) >0) do

    if x>y then x:=x-y

    else y:=y-x;

    writeln (x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На языке программирования Pascal создать программу нахождения наибольшего общего делителя (НОД) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Составьте программу нахождения наибольшего общего делителя трёх чисел, используя следующую формулу: НОД (A, B, C) = НОД (НОД (A, B), C). Нужно на паскале
Ответы (1)
1) Составить программу нахождения наибольшего общего делителя НОД. Составить блок-схему 2) Составить программу решения примера 1+2+4+6+8 ...
Ответы (1)
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)