Задать вопрос
20 февраля, 06:09

1) Составить программу нахождения наибольшего общего делителя НОД. Составить блок-схему

2) Составить программу решения примера

1+2+4+6+8 ...

+3
Ответы (1)
  1. 20 февраля, 08:22
    0
    Program pr1;

    var x, y, nod:integer;

    begin

    readln (x, y) ;

    repeat

    if x > y then x:=x mod y

    else y:=y mod x

    until x*y=0;

    nod:=x+y;

    writeln ('НОД=', nod) ;

    end.

    program pr2;

    var i, n, sum:integer;

    begin

    readln (n) ;

    sum:=1;

    for i:=1 to n do

    if i mod 2 = 0 then inc (sum, i) ;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Составить программу нахождения наибольшего общего делителя НОД. Составить блок-схему 2) Составить программу решения примера 1+2+4+6+8 ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы