Задать вопрос
21 августа, 01:01

Помогите написать программу на Паскале.

В целочисленной матрице размером 10x10 найдите максимальное значение и индексы всех элементов, равных ему.

+1
Ответы (1)
  1. 21 августа, 02:39
    0
    var

    ar: array[1 ... 10,1 ... 10] of integer;

    i, j, max, count:integer;

    begin

    count:=1;

    max:=0;

    randomize;

    for i:=1 to 10 do begin

    for j:=1 to 10 do begin

    ar[i, j]:=random (10) + 1;

    if (j mod 10=0) then writeln (ar[i, j]) else write (ar[i, j],' ') ;

    if (ar[i, j] > max) then max:=ar[i, j];

    end;

    end;

    for i:=1 to 10 do begin

    for i:=1 to 10 do begin

    for j:=1 to 10 do begin

    if (ar[i, j] = max) then begin

    writeln ('Индекс ', count,' элемента = ', i,' ', j) ;

    inc (count) ;

    end;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на Паскале. В целочисленной матрице размером 10x10 найдите максимальное значение и индексы всех элементов, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. в целочисленной матрице размерностью 3 х3 найти сумму наибольшего и наименьшего элементов матрицы паскаль 2. дан массив из 10 целых чисел. написать программу нахождения количества четных элементов массива
Ответы (1)
1) Двухцветное (черно-белое) растровое изоброжение имеет размер 10x10 точек. Какой объем памяти займет изображение. 2) Рассчитайте информационный объем 256-цветного изображения размером 10x10 точек.
Ответы (1)
В двоичной матрице размером 10x10 найдите совпадающие строки
Ответы (1)
Дан массив из тридцати элементов. Вывести индексы всех элементов, равных по значению а. Если таких элементов нет - вывести сообщение с текстом "No solution".
Ответы (1)
Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.
Ответы (1)