Задать вопрос
23 апреля, 05:50

Дан массив из тридцати элементов. Вывести индексы всех элементов, равных по значению а.

Если таких элементов нет - вывести сообщение с текстом "No solution".

Формат входных данных

На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) - элементы массива.

На второй строке записано целое положительное число a.

Формат выходных данных

Строка, содержащая искомые индексы, либо знадпись "No solution", если таковых нет.

+5
Ответы (1)
  1. 23 апреля, 08:25
    0
    Var

    i, x: integer;

    a: array[1 ... 30]of integer;

    b: boolean;

    begin

    b : = false;

    for i : = 1 to 30 do read (a[i]) ;

    readln (x) ;

    for i : = 1 to 30 do if (a[i] = x) then

    begin

    b : = true;

    write (i, ' ') ;

    end;

    if (b = false) then write ('No solution') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из тридцати элементов. Вывести индексы всех элементов, равных по значению а. Если таких элементов нет - вывести сообщение с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив из тридцати элементов. Проверьте, есть ли среди элементов стоящих на четных местах такой, значение которого лежит в интервале от a до b. Если такой элемент существует - напишите YES, иначе напишите NO.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только элементы с четными значениями. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только неотрицательные числа. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)