Задать вопрос
17 апреля, 05:58

Дан массив из тридцати элементов. Проверьте, есть ли среди элементов стоящих на четных местах такой, значение которого лежит в интервале от a до b.

Если такой элемент существует - напишите YES, иначе напишите NO.

Формат входных данных

На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) - элементы массива.

На второй строке записано целые положительные числа a и b.

Формат выходных данных

Строка, содержащая запись YES либо NO

+3
Ответы (1)
  1. 17 апреля, 09:21
    0
    Var

    i, x, y: integer;

    a: array[1 ... 30]of integer;

    begin

    readln (x, y) ;

    for i : = 1 to 30 do read (a[i]) ;

    for i : = 1 to 30 do if (i mod 2 = 0) and (a[i] > = x) and (a[i] < = y) then

    begin

    write ('YES') ;

    exit;

    end;

    write ('NO') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из тридцати элементов. Проверьте, есть ли среди элементов стоящих на четных местах такой, значение которого лежит в интервале от ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив из тридцати элементов. Вывести индексы всех элементов, равных по значению а. Если таких элементов нет - вывести сообщение с текстом "No solution".
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив целых чисел в диапазоне от - 30000 до 30000. Отсортировать его по убыванию. Методом простого выбора. Формат ввода: В первой строке - количество элементов массива не превосходящее 100. На второй строке через пробел элементы массива.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)