Задать вопрос
14 декабря, 19:22

Составьте программу, заменяющую больше из двух данных чисел удвоенным произведением, а меньшее полусуммой этих чисел

+5
Ответы (1)
  1. 14 декабря, 20:34
    0
    Uses crt;

    var a, b, c:real;

    begin

    read (a, b) ;

    c:=a;

    if a>b then

    begin

    a:=2*a*b;

    b: = (c+b) / 2;

    end

    else begin

    a: = (a+b) / 2;

    b:=2*c*b;

    end;

    writeln;

    write (a,' ', b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, заменяющую больше из двух данных чисел удвоенным произведением, а меньшее полусуммой этих чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы