Задать вопрос
20 декабря, 22:49

Определите количество шаров в пирамиде состоящей из n слоев если количество шаров в слое равно квадрату номера слоя

+3
Ответы (1)
  1. 21 декабря, 00:38
    0
    Var n, s, i: integer;

    begin

    write ('Количество слоев: ') ;

    readln (n) ;

    for i : = 1 to n do

    s:=s+i*i;

    writeln ('Число шаров: ', s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определите количество шаров в пирамиде состоящей из n слоев если количество шаров в слое равно квадрату номера слоя ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Цикл. Блок-схема. Вычислите и выведите на экран количество шаров в пирамиде из N слоев и количeство шаров в каждом слое, если количество шаров в каждом слое равно квадрату порядкового номера слоя.
Ответы (1)
Имеется пирамида, в основании которой находится квадрат со стороной из N шаров. Следующий слой пирамиды состоит из шаров, лежащих в углублениях нижнего слоя, т. е. представляет собой квадрат со стороной N-1 шаров и т. д. Верхний слой содержит 1 шар.
Ответы (1)
5. В ящике лежат 70 шаров, отличающихся лишь цветом: 20 красных, 20 синих, 20 жёлтых, остальные чёрные и белые. a. Какое наименьшее число шаров надо взять, из черного ящика, чтобы среди них было не меньше 10 шаров одного цвета? b.
Ответы (1)
В корзине лежат 100 шаров. Известно, что некоторые из них черного цвета, а некоторые белого. Количество белых шаров - натуральное число. Сколько шаров белого цвета лежит в корзине, если известно, что из двух любых шаров хотя бы один черный?
Ответы (2)
48 шаров разложили на три попарно неравные кучки. Если из первой кучки переложить во вторую столько шаров, сколько в этой второй кучке было, затем из второй в третью переложить столько, сколько в этой третьей перед тем будет находиться, и из третьей
Ответы (1)