Задать вопрос
30 октября, 01:12

Имеется пирамида, в основании которой находится квадрат со стороной из N шаров. Следующий слой пирамиды состоит из шаров, лежащих в углублениях нижнего слоя, т. е. представляет собой квадрат со стороной N-1 шаров и т. д. Верхний слой содержит 1 шар. Определить, сколько шаров потребуется для строительства пирамиды из N слоев.

+3
Ответы (1)
  1. 30 октября, 03:58
    0
    Var N, k, i: integer;

    begin

    write (' N = ') ;

    readln (N) ;

    k:=0;

    for i:=N downto 1 do

    k:=k+i*i;

    writeln ('k=', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Имеется пирамида, в основании которой находится квадрат со стороной из N шаров. Следующий слой пирамиды состоит из шаров, лежащих в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Снеговика лепили по алгоритму. Какой снеговик получился? 1. Скатай большой шар. 2. Скатай средний шар и положи его на большой шар. 3. Скатай маленький шар и положи его на средний шар. 4. В маленький шар воткни морковку. 5.
Ответы (1)
Цикл. Блок-схема. Вычислите и выведите на экран количество шаров в пирамиде из N слоев и количeство шаров в каждом слое, если количество шаров в каждом слое равно квадрату порядкового номера слоя.
Ответы (1)
А) 5 Кб = ? Байтовб) 6 Мбайт = ? Кбайтв) 1024 бит = ? Кбайт 2. Сколько Мбайт информации содержит сообщение объемом 2 28 бит?. 3. Сколько бит информации содержит сообщение объемом 16 Кб? 4.
Ответы (1)
Определите количество шаров в пирамиде состоящей из n слоев если количество шаров в слое равно квадрату номера слоя
Ответы (1)
Известно, что в ящике лежат 10 чёрных шаров, 5 белых, 4 жёлтых и 1 красный. Какое количество информации несут сообщения о том, что из ящика случайным образом достали чёрный шар, белый шар, жёлтый шар, красный шар?
Ответы (1)