Задать вопрос
20 декабря, 23:42

Написать программу в Pascal по циклам:

Ежедневно ученик делает в диктанте разное кол-во ошибок. За сколько дней кол-во ошибок достигнет числа q? (Написать программу с циклом while)

+1
Ответы (1)
  1. 21 декабря, 01:12
    0
    Program gt;

    var q, k, a, s:integer;

    begin

    writeln ('Задайте q') ;

    readln (q) ;

    k:=-1; s:=0;

    while q>s do

    begin

    k:=k+1;

    read (a) ;

    s:=s+a;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Pascal по циклам: Ежедневно ученик делает в диктанте разное кол-во ошибок. За сколько дней кол-во ошибок достигнет ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если выполнения алгоритма заканчивается, когда условие цикла становится истинным, то он называется: 1) циклом с предусловием 2) бесконечность 3) циклом n-раз 4) циклом с постусловием
Нет ответа
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b (от1 до 100). Нужно составить 1 - с циклом с пред условием, 2 - с циклом с пост условием
Ответы (1)
Найти сумму семи нечетных чисел натурального ряда, начиная с N>0. N вводится с клавиатуры. Сделать нужно по 3 циклам в паскале (repeat until, for to do, while do)
Ответы (1)