Задать вопрос
28 марта, 01:34

Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b (от1 до 100).

Нужно составить 1 - с циклом с пред условием, 2 - с циклом с пост условием

+3
Ответы (1)
  1. 28 марта, 03:47
    0
    1)

    var sum:integer;

    a, b:integer;

    begin

    a:=1;

    readln (b) ;

    for a:=1 to 99 do begin

    if a mod b = 0 then

    sum:=sum+a;

    end;

    writeln (sum) ;

    end.

    2)

    var sum:integer;

    a, b:integer;

    begin

    a:=1;

    readln (b) ;

    repeat

    if a mod b = 0 then

    sum:=sum+a;

    inc (a) ;

    until a=100

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b (от1 до 100). Нужно составить 1 - с циклом с пред ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя способами) 2. Составить программу вычисления суммы всех трехзначных чисел, кратных 17. (паскаль, тремя способами)
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Если выполнения алгоритма заканчивается, когда условие цикла становится истинным, то он называется: 1) циклом с предусловием 2) бесконечность 3) циклом n-раз 4) циклом с постусловием
Нет ответа
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)