Задать вопрос
5 августа, 10:59

Написать программу которая выводит на экран значений функции у=|х|. диапазон изменения аргумента-от4 до - 4, шаг приращения - (-0.5)

+3
Ответы (2)
  1. 5 августа, 11:15
    0
    Если я правильно понял, то так

    uses crt;

    varx, y:real;

    beginx:=4;

    while x> (-4.5) do begin

    y:=abs (x) ;

    x:=x + (-0.5) ;

    write (y,' ') ;

    end;

    end.
  2. 5 августа, 11:28
    0
    Вот так:

    const

    LB=-4;

    HB=4;

    DX=0.5;

    var

    x, y : real;

    n, i : integer;

    begin

    writeln ('значения') ;

    n:=round ((HB-LB) / DX) + 1;

    x:=LB;

    for i: = 1 to n do

    begin

    y:=abs (x) ;

    writeln (x:6:2, y:6:2) ;

    x:=x+DX;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая выводит на экран значений функции у=|х|. диапазон изменения аргумента-от4 до - 4, шаг приращения - (-0.5) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите, по программе паскаль Написать программу, которая выводит табличные значения функции у=х2+2. Диапазон изменения аргумента от - 4 до 4, шаг аргумента 1
Ответы (1)
1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов. 2. Написать прогрумму, которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Написать программу, которая выводит на экран результаты следующих действий: 27-5= 11+21= 32/2= 2+2*2= (2+2) * 2= Написать программу, которая выводит на экран результаты следующих действий: 21-4= 21+11= 43/3= 3+3*3= (3+3) * 3=
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)