Задать вопрос
7 ноября, 13:02

Случайным образом задано 1000
+2

Ответы (1)
  1. 7 ноября, 14:40
    0
    Var

    a:array[1 ... 100]of integer;

    n, i, c, k, j, x:integer;

    begin

    readln (n) ;

    c:=n;

    while n0 do begin

    n:=n div 10;

    k:=k+1;

    end;

    for i:=1 to k do begin

    a[i]:=c mod 10;

    c:=c div 10;

    end;

    for i:=1 to k do

    write (a[i],' ') ;

    j:=2;

    for i:=1 to k do begin

    while jk do begin

    if (a[i]=a[j]) and (ij) then

    x:=x+1;

    j:=j+1;

    end;

    j:=2;

    end;

    writeln;

    write (x,' повторов') ;

    writeln; i

    f x=0 then writeln ('все числа различны')

    else writeln ('числа в числе повторяются')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Случайным образом задано 1000 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать и отладить программу, вычисляющую семь значение функции y=x^2+1, где x-задано случайным образом в интервале (-4; 7)
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (2)
Задача на Паскале (нужно полное решение) Задан массив случайным образом. Преобразовать его след. образом: все отрицательные элементы заменить модулем, положительные удвоить, нулевые заменить числом 10
Ответы (1)
Составить программу: 1. Задано пятизначное число. Выделить цифры, стоящие в разряде единиц и разряде тысяч. Вывести их в порядке убывания 2. Задано четырехзначное число. Удалить из записи числа последнюю цифру.
Ответы (1)
На паскале нужно решить задачи 1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа. 2. Задано трехзначное число.
Ответы (1)