Задать вопрос
21 августа, 21:46

Дана строка. Среди символов строки встречаются цифры. Написать программу, вычисляющую сумму всех цифр строки.

+2
Ответы (1)
  1. 21 августа, 22:10
    0
    Pascal

    ---

    var s:string;

    i, c, sum:integer;

    begin

    readln (s) ;

    sum: = 0;

    for i:=1 to Length (s) do

    if (s[i]>='0') and (s[i]<='9') then

    begin

    c:=ord (s[i]) - 48;

    sum:=sum+c;

    end;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка. Среди символов строки встречаются цифры. Написать программу, вычисляющую сумму всех цифр строки. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка. среди символов встречаются цифры. написать программу, вычисляющую сумму всех цифр
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)