Задать вопрос
3 декабря, 10:46

дано натуральное число N найти количество нулей в этом числе

+4
Ответы (1)
  1. 3 декабря, 14:00
    0
    Var

    n, c : integer;

    begin

    c : = 0;

    read (n) ;

    while (n > 0) do

    begin

    if (n mod 10 = 0) then c : = c + 1;

    n : = n div 10;

    end;

    write (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дано натуральное число N найти количество нулей в этом числе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число N (N> 9). Определить количество нулей в цифровой записи числа, кроме нулей в младших разрядах. Пример. N=10 025 000. Количество нулей равно двум.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Дано натуральное число N. Напишите функцию (Pascal), определяющую количество нулей среди всех цифр числа N. Входные данные Задано единственное число N Выходные данные Необходимо вывести количество нулей среди всех цифр числа N.
Ответы (1)
Дан массив с1, с2, ..., с15, состоящий из нулей и единиц. Подсчитать количество нулей, количество единиц и количество нулей до первой единицы. Это в паскале
Ответы (1)
Написать прогу на пвскале 6. Дано натуральное число N (N > 9). Определить количество нулей, идущих подряд в младших разрядах данного числа. Пример. N = 1020000. Количество нулей равно четырем.
Ответы (1)