Задать вопрос
30 июля, 08:27

Помогите решить две задачи с помощью "паскаля"

1) Ученик выучил в первый день 5 английских слов, а последующие дни он учил на два слова больше чем в предыдущие через сколько дней он выучит 250 слов?

2) Вычислить сумму и произведения натурального числа от 1 до 20.

+3
Ответы (1)
  1. 30 июля, 10:10
    0
    1.

    var k, x, y:integer;

    begin

    x:=5; k:=1;

    while y<250 do

    begin

    x:=x+2;

    y:=y+x;

    k:=k+1;

    end;

    writeln (k) ;

    end.

    2.

    var s, p, x:longint;

    begin

    for x:=1 to 20 do

    begin

    s:=s+x;

    p:=p*x;

    end;

    writeln ('Сумма=', s,'. Произведение=', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить две задачи с помощью "паскаля" 1) Ученик выучил в первый день 5 английских слов, а последующие дни он учил на два слова ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ученик в первый день выучил 5 англисских слов. В каждый следующий день он выучивал на 2 слова больше, чем в предыдущий. Сколько англисских слов выучит ученик в 10 дней занятий?. Составьте алгоритм или программу!
Ответы (1)
Составить программу в Паскаль: Ученик в первый день выучил Х английских слов. В каждый следующий день он выучивал на К слов больше, чем в предыдущий. Сколько английских слов он будет знать в N-й день занятий?
Ответы (2)
В первый день Знайка выучил два иностранных слово в каждый следующей в два раза больше чем в предыдущий сколько всего слов выучит Знайка за 15 дней
Ответы (1)
Мальчик учит англ слова. в первый день он выучил 10 слов, каждый следующий день он учил на 5 слов больше, чем в предыдущий. через сколько дней словарный запас мальчика будет более 120 слов
Ответы (1)
1. Что такое цикл? 2. Чем отличаются циклы с предусловием и постусловием? 3. Сколько раз выполнится цикл? n:=0 while n
Ответы (1)