Задать вопрос
1 мая, 02:37

Составить программу в Паскаль: Ученик в первый день выучил Х английских слов. В каждый следующий день он выучивал на К слов больше, чем в предыдущий. Сколько английских слов он будет знать в N-й день занятий?

+1
Ответы (2)
  1. 1 мая, 04:12
    0
    На первую часть задачи можно ответить устно без калькулятора. Складываем подряд цифры за десять дней начиная с 5 в первый день и завершая 23 в десятый. Итого: 5+7+9+11+13+15+17+19+21+23=140. 140 слов он будет знать на 10-ый день. 250 слов получится на 14-ый день. Второй способ подсчета - блок-схема: var i, p, s:integer; begin i:=1; p:=5; s:=p; repeat i:=i+1; p:=p+2; s:=s+p until s>=250; writeln (i) end. Расшифровка: i - дни. Они увеличиваются на один. p - количество слов, изначально пять, но потом по две добавляется. Сумма больше или равно 250. Подсчитать количество дней. В ответе также будет 14.
  2. 1 мая, 04:37
    0
    Var x, k, n, s, i:integer;

    begin

    writeln ('x, k, n:') ;

    readln (x, k, n) ;

    s:=x;

    for i:=2 to n do

    begin

    x:=x+k;

    s:=s+x;

    end;

    writeln ('s = ', s) ;

    end.

    Пример:

    x, k, n:

    10 2 5

    s = 70
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в Паскаль: Ученик в первый день выучил Х английских слов. В каждый следующий день он выучивал на К слов больше, чем в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ученик в первый день выучил 5 англисских слов. В каждый следующий день он выучивал на 2 слова больше, чем в предыдущий. Сколько англисских слов выучит ученик в 10 дней занятий?. Составьте алгоритм или программу!
Ответы (1)
1. Что такое цикл? 2. Чем отличаются циклы с предусловием и постусловием? 3. Сколько раз выполнится цикл? n:=0 while n
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Мальчик учит англ слова. в первый день он выучил 10 слов, каждый следующий день он учил на 5 слов больше, чем в предыдущий. через сколько дней словарный запас мальчика будет более 120 слов
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)