Задать вопрос
14 октября, 17:16

1. Дан целочисленный массив из двадцати пяти элементов. Элементы могут принимать значения от - 500 до 500. Найти минимальное значение среди элементов массива которые имеют четное значение и не деляться на 7.

+2
Ответы (1)
  1. 14 октября, 18:23
    0
    Var a: array [1 ... 25] of integer;

    i, m, c: integer;

    begin

    for i : = 1 to 25 do

    begin

    a[i] : = random (1000) - 500;

    writeln ('[', i, '] = > ', a[i]) ;

    end;

    m : = 501;

    for i : = 1 to 25 do

    if ((m > a[i]) and (a[i] mod 2 = 0) and (i mod 7 > 0)) then

    begin

    m : = a[i];

    c : = i;

    end;

    writeln ('[', c, '] = > ', a[c]) ;

    end.

    Так=)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дан целочисленный массив из двадцати пяти элементов. Элементы могут принимать значения от - 500 до 500. Найти минимальное значение среди ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от - 1000 до 1000 включительно. Опишите алгоритм, позволяющий найти и вывести минимальное значение среди отрицательных элементов массива, оканчивающихся на 3.
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)