Задать вопрос
27 ноября, 15:48

Составьте программу, которая осущ ввод в массив с клавиатуры 10 целых чисел и вычисляет: четные числа умножает на 3, а нечетные - на 4

+4
Ответы (1)
  1. 27 ноября, 17:28
    0
    Var i:longint; m:array[1 ... 10] of longint;

    Begin

    for i:=1 to 10 do

    begin

    read (m[i]) ;

    if m[i] mod 2 = 1 then

    m[i]:=m[i]*4 else

    m[i]:=m[i]*3;

    end;

    for i:=1 to 10 do

    write (m[i],' ') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая осущ ввод в массив с клавиатуры 10 целых чисел и вычисляет: четные числа умножает на 3, а нечетные - на 4 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая формирует массив из 15 случайных целых цифр от - 20 до 20 и чётные цифры делит на 2, а нечётные-умножает на 3
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Cоставьте программу которая формирует массив из пятнадцати случайных чисел от - 20 до 20 и четные числа делит на два, а нечетные - умножает на 3. (9 класс).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)