Задать вопрос
18 августа, 02:25

Составьте программу, которая формирует массив из 15 случайных целых цифр от - 20 до 20 и чётные цифры делит на 2, а нечётные-умножает на 3

+5
Ответы (1)
  1. 18 августа, 03:43
    0
    На каком языке нужна программа?

    Пример на Paskal:

    program zadacha;

    var massiv: array [1 ... 15] of integer; i:byte; massiv2:array [1 ... 15] of real;

    begin

    randomize;

    write ('Isxodnij massiv: ') ;

    for i:=1 to 15 do

    begin

    massiv:=random (41) - 20;

    write (massiv,' ') ;

    end;

    writeln;

    writeln ('Massiv posle preobrazovanij: ') ;

    for i:=1 to 15 do

    begin

    if massiv=0 then massiv2:=massiv

    else

    if massiv mod 5 = 0 then massiv2:=massiv*2

    else begin

    massiv2:=massiv;

    massiv2:=massiv2/2;

    end;

    write (massiv2:0:1,' ') ;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая формирует массив из 15 случайных целых цифр от - 20 до 20 и чётные цифры делит на 2, а нечётные-умножает на 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Cоставьте программу которая формирует массив из пятнадцати случайных чисел от - 20 до 20 и четные числа делит на два, а нечетные - умножает на 3. (9 класс).
Ответы (1)
Программа которая формирует массив из 15 случайных целых чисел от - 20 до 20 и чётные исла делит на два, а нечётные-умножает на три
Ответы (1)
Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0; 7], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 3, а к нечётное умножает на 4
Ответы (1)
Сосавить программу, которая формирует массив, содержащий 8 случайных целых чисел, принадлежащих промежутку[0; 6] и преобразует элементы массива по следующему правилу: четное число умножает на 3, а к нечетному прибавляет 2
Ответы (2)
Составить программу которая формирует массив содержащий 8 случайных целых чисел принадлежащих промежутку [0 ... 5 ] и преобразует элементы массива по следующему правилу: четное число умножает на 5, а от нечетного отнимает 2.
Ответы (1)