Задать вопрос
14 ноября, 02:20

Сосавить программу, которая формирует массив, содержащий 8 случайных целых чисел, принадлежащих промежутку[0; 6] и преобразует элементы массива по следующему правилу: четное число умножает на 3, а к нечетному прибавляет 2

+1
Ответы (2)
  1. 14 ноября, 04:24
    0
    Program Program1;

    var

    a:array [1 ... 8] of integer;

    i:integer;

    s:string;

    begin

    randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to 8 do

    begin

    a[i]:=random (7) ;

    writeln ('a[', i,']=', a[i]) ;

    end;

    for i:=1 to 8 do

    if a[i] mod 2 = 0 then

    a[i]:=a[i]*3

    else

    a[i]:=a[i]+2;

    writeln;

    writeln ('Преобразованный массив:') ;

    for i:=1 to 8 do

    writeln ('a[', i,']=', a[i]) ;

    end.
  2. 14 ноября, 04:33
    0
    var a:array [1 ... 8] of integer;

    i:integer;

    begin

    for i:=1 to 8 do

    read (a[i]) ;

    for i:=1 to 8 do

    if (a[i]) div 2 = 0 then a[i]: = (a[i]) * 3

    else a[i]:=a[i]+2;

    for i:=1 to 8 do

    writeln (a[i]) ;

    end.

    тока добавь что числа в промежутке [0 ... 6]
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сосавить программу, которая формирует массив, содержащий 8 случайных целых чисел, принадлежащих промежутку[0; 6] и преобразует элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу которая формирует массив содержащий 8 случайных целых чисел принадлежащих промежутку [0 ... 5 ] и преобразует элементы массива по следующему правилу: четное число умножает на 5, а от нечетного отнимает 2.
Ответы (1)
Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0; 7], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 3, а к нечётное умножает на 4
Ответы (1)
Составьте программу, которая формирует массив, содержащий 15 случайныхцелых чисел, принадлежащих промежутку [0; 8] и преобразует элементы массива по следующему правилу: к четному числу прибавляет 1, а нечетное умножает на 2.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Сформировать массив содержащий 15 случайных целых чисел, принадлежащих промежутку [0; 8] и преобразовать элементы массива по следующему правилу: к четному прибавить 1, а нечетное умножить на 2.
Ответы (1)