Задать вопрос
2 декабря, 12:46

Составьте программу, которая формирует массив, содержащий 15 случайныхцелых чисел, принадлежащих промежутку [0; 8] и преобразует элементы массива по следующему правилу: к четному числу прибавляет 1, а нечетное умножает на 2.

+5
Ответы (1)
  1. 2 декабря, 13:40
    0
    Program Frank;

    const n=15;

    Type mas=array[1 ... n] of integer;

    var a:mas; i:integer;

    begin

    for i:=1 to n do begin

    a[i]:=random (8) ;

    write (' ', a[i]) ;

    end;

    for i:=1 to n do begin

    if a[i] mod 2=0 then a[i]:=a[i]+1

    else a[i]:=a[i]*2;

    write (' Получили ', a[i]) ;

    end;

    end.

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая формирует массив, содержащий 15 случайныхцелых чисел, принадлежащих промежутку [0; 8] и преобразует элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0; 7], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 3, а к нечётное умножает на 4
Ответы (1)
Сосавить программу, которая формирует массив, содержащий 8 случайных целых чисел, принадлежащих промежутку[0; 6] и преобразует элементы массива по следующему правилу: четное число умножает на 3, а к нечетному прибавляет 2
Ответы (2)
Составить программу которая формирует массив содержащий 8 случайных целых чисел принадлежащих промежутку [0 ... 5 ] и преобразует элементы массива по следующему правилу: четное число умножает на 5, а от нечетного отнимает 2.
Ответы (1)
Сформировать массив содержащий 15 случайных целых чисел, принадлежащих промежутку [0; 8] и преобразовать элементы массива по следующему правилу: к четному прибавить 1, а нечетное умножить на 2.
Ответы (1)
Программа: формирует массив содержащий 15 случайных целых чисел принадлежащих промежутку [0 ... 8] и прибавлчет 1 а нечётное умножает на 2
Ответы (1)