Задать вопрос
13 июля, 12:44

Программа: формирует массив содержащий 15 случайных целых чисел принадлежащих промежутку [0 ... 8] и прибавлчет 1 а нечётное умножает на 2

+2
Ответы (1)
  1. 13 июля, 14:39
    0
    Var

    a:array[1 ... 15] of integer;

    c, e:real; i:integer;

    begin

    randomize;

    for i:=1 to 15 do

    begin

    a[i]:=random (9) ;

    end;

    for i:=1 to 15 do

    begin

    e:=a[i] div 2;

    c:=a[i]/2;

    if a[i]=0 then write (a[i],' ')

    else

    begin

    if e=c then

    begin

    c:=a[i]+1;

    write (c,' ') ;

    end

    else

    begin

    c:=a[i]*2;

    write (c,' ') ;

    end;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа: формирует массив содержащий 15 случайных целых чисел принадлежащих промежутку [0 ... 8] и прибавлчет 1 а нечётное умножает на 2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сосавить программу, которая формирует массив, содержащий 8 случайных целых чисел, принадлежащих промежутку[0; 6] и преобразует элементы массива по следующему правилу: четное число умножает на 3, а к нечетному прибавляет 2
Ответы (2)
Составить программу которая формирует массив содержащий 8 случайных целых чисел принадлежащих промежутку [0 ... 5 ] и преобразует элементы массива по следующему правилу: четное число умножает на 5, а от нечетного отнимает 2.
Ответы (1)
Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0; 7], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 3, а к нечётное умножает на 4
Ответы (1)
Составьте программу, которая формирует массив, содержащий 15 случайныхцелых чисел, принадлежащих промежутку [0; 8] и преобразует элементы массива по следующему правилу: к четному числу прибавляет 1, а нечетное умножает на 2.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)