Задать вопрос
1 мая, 10:37

Сформировать массив содержащий 15 случайных целых чисел, принадлежащих промежутку [0; 8] и преобразовать элементы массива по следующему правилу: к четному прибавить 1, а нечетное умножить на 2.

+4
Ответы (1)
  1. 1 мая, 11:22
    0
    Program FindMin;

    uses crt;

    var

    a:array[1 ... 15] of integer;

    min, i:integer;

    begin

    for i:=1 to 15 do begin

    a[i]:=random (9) ;

    Write (a[i],' ') ;

    end;

    for i:=1 to 15 do

    if a[i] mod 2 = 0 then

    a[i]:=a[i]+1

    else

    a[i]:=a[i]*2;

    Writeln;

    for i:=1 to 15 do begin

    Write (a[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать массив содержащий 15 случайных целых чисел, принадлежащих промежутку [0; 8] и преобразовать элементы массива по следующему ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0; 7], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 3, а к нечётное умножает на 4
Ответы (1)
Составьте программу, которая формирует массив, содержащий 15 случайныхцелых чисел, принадлежащих промежутку [0; 8] и преобразует элементы массива по следующему правилу: к четному числу прибавляет 1, а нечетное умножает на 2.
Ответы (1)
Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С, В которые содержат: массив В - четные элементы из массива А в порядке их следования в массиве А, массив С - отрицательные элементы массива А в
Ответы (1)
Сосавить программу, которая формирует массив, содержащий 8 случайных целых чисел, принадлежащих промежутку[0; 6] и преобразует элементы массива по следующему правилу: четное число умножает на 3, а к нечетному прибавляет 2
Ответы (2)
Составить программу которая формирует массив содержащий 8 случайных целых чисел принадлежащих промежутку [0 ... 5 ] и преобразует элементы массива по следующему правилу: четное число умножает на 5, а от нечетного отнимает 2.
Ответы (1)