Задать вопрос
16 октября, 15:04

Двумерные массивы. Помогите написать программу:

заполнить массив 3 х10

там вот так получается:

1 2 3 4 ... 10

5 10 15 20 25 ...

25 50 75 100 ...

По какой-то формуле.

Заранее благодарю))

+4
Ответы (1)
  1. 16 октября, 15:35
    0
    Var a: array [1 ... 3, 1 ... 10] of integer;

    i, m, j: integer;

    begin

    for i : = 1 to 3 do

    for j : = 1 to 10 do

    begin

    if (i = 1) then a[i, j] : = j;

    if (i = 2) then a[i, j] : = 5 * j;

    if (i = 3) then a[i, j] : = 25 * j;

    writeln ('[', i, ', ', j, '] = > ', a[i, j]) ;

    end;

    end.

    Удачи)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Двумерные массивы. Помогите написать программу: заполнить массив 3 х10 там вот так получается: 1 2 3 4 ... 10 5 10 15 20 25 ... 25 50 75 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу с использованием процедуры или функции. Объявлен массив целых чисел. m размером 5 х10. Заполнить массив числами из промежутка [-20,20]. Каждый элемент массива заменить его кубом. Исходный и измененный массив вывести на экран.
Ответы (1)
Двумерные массивы. Paskal Дан массив целых чисел (n=20), заполненный случайным образом числами из промежутка [-45; 95].
Ответы (1)
Дана целочисленная матрица А размером М х N, где М и N вводятся с клавиатуры. Сформировать одномерный массив В, где В[i] равно сумме элементов кратных трем в i-ой строке. Если таких элементов нет, то В[i] равно - 10. Двумерные массивы
Ответы (1)
Python! Нужно составить программы к задачам. Тема:"Двумерные массивы" 1) Даны три матрицы разных порядков. Найти среди них матрицу с наибольшим количеством чётных элементов.
Ответы (1)
Дан массив С (10). Сформируйте из него массивы А (5) и В (5), предварительно определив их длину. В массив А включите элементы из массива С с четными индексами, а в В - с нечетными. Выведите на экран массивы А (5), В (5) и С (10).
Ответы (1)