Задать вопрос
21 октября, 03:40

Дана целочисленная матрица А размером М х N, где М и N вводятся с клавиатуры. Сформировать одномерный массив В, где В[i] равно сумме элементов кратных

трем в i-ой строке. Если таких элементов нет, то В[i] равно - 10.

Двумерные массивы

+5
Ответы (1)
  1. 21 октября, 04:54
    0
    Var

    A : array[1 ... 100,1 ... 100] of Integer;

    B : array[1 ... 100] of Integer;

    M, N, s, i, j : Integer;

    Begin

    Readln (M, N) ;

    For i:=1 to M do

    Begin

    s:=0;

    For j:=1 to N do

    Begin

    A[i, j]:=Random (100) ;

    Write (A[i, j]:4) ;

    If A[i, j] mod 3 = 0 then s:=s+A[i, j];

    end;

    If s=0 then B[i]:=-10 else B[i]:=s;

    Writeln (' ', B[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана целочисленная матрица А размером М х N, где М и N вводятся с клавиатуры. Сформировать одномерный массив В, где В[i] равно сумме ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Информатика. Массивы Массив A вводится с клавиатуры. Сформировать новый массив B, состоящий из чётны элементов массива А. Элементы вводятся с клавиатуры. Размер произвольный.
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)
Даны массивы A (m) и B (m), m меньше либо равно 10. Сформировать массив С по правилу: C1=A1, C2=B1, C3=A2, C4=B2 и т. д. Вывечти на печать исходные массивы A и B и сформировать массив Матлаб или бейсик
Ответы (1)