Задать вопрос
10 февраля, 18:32

Вычислить сумму ряда 1 - 1/2 + 1/3 - ... + 1/999 - 1/1000 справа - налево, в паскале

+4
Ответы (1)
  1. 10 февраля, 19:15
    0
    Var x, y: Real;

    i: integer;

    begin

    for i : = 1000 downto 1 do

    begin

    if (i mod 2 = 0) then y : = - 1 * i

    else y : = i;

    writeln ('1/', i) ;

    x : = x + 1 / y;

    end;

    writeln ('> ', x) ;

    end.

    А вручную это пришлось бы минут 30 даже с калькулятором считать х_х
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить сумму ряда 1 - 1/2 + 1/3 - ... + 1/999 - 1/1000 справа - налево, в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Где ошибка? Является ли заданное натуральное четырехзначное число палиндромом? Палиндромами называются числа, которые читаются одинаково слева-направо и справа-налево. Напрмер, 8998, 3333. Вводится целое число N (999 < N
Ответы (1)
Дано натуральное число. Выяснить, является ли оно палиндромом ("перевертышем"), т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. Помогите написать на паскале
Ответы (1)
Помогите написать программу на паскале абс Дано трехзначное число. Найдите его палиндром и произведение палиндрома и данного числа. Числовой палиндром - это натуральное число, которое читается слева направо и справа налево одинаково.
Ответы (1)
Программирование логических выражений. Написать программу в Паскале. Данное четырёхзначное число читается одинаково слева направо и справа налево.
Ответы (1)