Задать вопрос
20 марта, 18:01

Написать на паскале программу на признак делимости, которая выводит, делится ли число на 11 или нет, с участием функции

+1
Ответы (2)
  1. 20 марта, 18:12
    0
    То, что написал Alex - это не функция проверки признака делимости,

    а стандартная функция остатка от деления, которая тебе не подходит.

    Признак делимости на 11 такой. Нужно отдельно сложить цифры, стоящие на нечетных местах - 1, 3, 5, ..., до конца, и отдельно цифры, стоящие на четных местах - 2, 4, 6, ..., тоже до конца.

    Потом вычитаешь из большего числа меньшее. Если разность = 0 или делится на 11, то и все число делится на 11.

    Я паскаль плохо знаю, поэтому опишу только алгоритм.

    1) Вводим начальное число N.

    2) Объявляем массив M[length (N) ] длиной, равной количеству цифр числа.

    3) Делаем в цикле a : = N mod 10; M[i] : = a; N : = int (N / 10) ; i : = i+1;

    Продолжаем цикл до тех пор, пока N > 0.

    4) S1 : = 0; Цикл от 1 до length (N) с шагом 2: S1 : = S1 + A[i];

    5) S2 : = 0; Цикл от 2 до length (N) с шагом 2: S2 : = S2 + A[i];

    6) Raznost : = abs (S1 - S2) ;

    7) Если Raznost mod 11 = 0 тогда ответ ДА, иначе ответ НЕТ.

    8) Конец
  2. 20 марта, 20:22
    0
    Var

    chislo:integer;

    begin

    writeln ('Введите число') ;

    readln (chislo) ;

    if ((chislo mod 11) = 0) then

    writeln ('делится')

    else

    writeln ('не делится') ;

    readln;

    readln

    end.

    вроде так

    будут ошибки пиши
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать на паскале программу на признак делимости, которая выводит, делится ли число на 11 или нет, с участием функции ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. написать программу которая, используя признаки делимости, определяет, делится ли число на 6. var a, c: integer; begin cls; randomize; a:=random (99999+99999+1) - 99999; writeln ('исходное числo: ', a) ;
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Написать программу, которая выводит на экран результаты следующих действий: 27-5= 11+21= 32/2= 2+2*2= (2+2) * 2= Написать программу, которая выводит на экран результаты следующих действий: 21-4= 21+11= 43/3= 3+3*3= (3+3) * 3=
Ответы (1)