Задать вопрос
28 апреля, 19:03

В соревнованиях по прыжкам в длину участвуют 25 спортсменов, с клавиаиуры ввести номер спортсмена и его результат (номер спортсмена не связан с очередностью). Написать программу, которая выводит на экран номер и результат худшего и лучшего спортсменов. все это как то связанно с оператором повтора FOR

+2
Ответы (1)
  1. 28 апреля, 22:20
    0
    Var a, b:array[1 ... 25] of integer;

    i, min, max:integer;

    begin

    max:=1;

    min:=1;

    for i:=1 to 25 do begin

    read (a[i]) ;

    read (b[i]) ;

    if a[i]>a[max] then max:=i;

    if a[i]
    end;

    writeln ('Лучший - ', a[max],' длина - ', b[max]) ;

    writeln ('Худший - ', a[min],' длина - ', b[min]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В соревнованиях по прыжкам в длину участвуют 25 спортсменов, с клавиаиуры ввести номер спортсмена и его результат (номер спортсмена не ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Написать программу, которая выводит на экран результаты следующих действий: 27-5= 11+21= 32/2= 2+2*2= (2+2) * 2= Написать программу, которая выводит на экран результаты следующих действий: 21-4= 21+11= 43/3= 3+3*3= (3+3) * 3=
Ответы (1)
Помогите по программе paskal: 1. дано целое число. напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора результат 2. дано целое число.
Ответы (1)
30 спортсменов приняло участие в соревнованиях по. бегу 12 по прыжкам в длину 10 по бегу и прыжкам в длину сколько всего спортсменов участвовало в соревнованиях
Ответы (1)