Задать вопрос
8 апреля, 11:52

Дан

целочисленный массив A (N). Найти наибольшее из нечетных и количество четных чисел, входящих в

последовательность A[1], ..., A[n], A[n]+1.

+5
Ответы (1)
  1. 8 апреля, 14:49
    0
    Program gt;

    var n, i, max, l:integer;

    a:array[1 ... 100]of integer;

    begin

    read (n) ;

    max:=0; l:=0;

    for i:=1 to n+1 do

    begin

    read (a[i]) ;

    if (abs (a[i]) mod 2=0) then l:=l+1;

    if ((abs (a[i]) mod 2=1) and (a[i]>max)) or (max mod 2=0) then max:=a[i];

    end;

    writeln (max) ;

    writeln (l) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив A (N). Найти наибольшее из нечетных и количество четных чисел, входящих в последовательность A[1], ..., A[n], ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1. Сформируйте и выведите целочисленный массив содержащий N первых положительных четных (нечетных) чисел 2. Сформируйте и выведите целочисленный массив содержащий степени двойки от первой до 16-й: 2,4,8,16,32 ...
Ответы (1)