Задать вопрос
31 декабря, 06:17

Программа выполняется в Паскале! Составьте программу для решения следующей задачи: Дядюшка подарил своему племяннику на первый день рождения 1 доллар. В каждый следующий день рождения он удваивал свой подарок и прибавлял к нему столько долларов, сколько лет исполнилось его племяннику. Определите, к какому дню рождения сумма превысит 100 долларов? Помогите плииз.

+2
Ответы (1)
  1. 31 декабря, 09:48
    0
    Var money, n, count:integer;

    begin

    money:=1;

    n:=0;

    while money < 100 do

    begin

    money: = money*2+n;

    n:=n+1;

    count:=count+1;

    end;

    writeln (count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа выполняется в Паскале! Составьте программу для решения следующей задачи: Дядюшка подарил своему племяннику на первый день ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Мой богатый дядюшка подарил мне 1 доллар в мой первый день рождения. В каждый следующий день рождения он удваивал свой подарок и прибавлял к нему столько долларов, сколько лет мне исполнилось.
Ответы (1)
Один богатый дядюшка подарил племяннику 1 доллар в его первый день рождения. В каждый следующий день рождения он удваивал подарок и прибавлял к нему столько долларов, сколько лет исполнялось мальчику.
Ответы (1)
Мой богатый дядюшка подарил мне один доллар на мой первый день рождения. В каждый следующий день рождения он удваивал свой прошлогодний подарок, прибавлял к нему столько долларов, сколько лет мне исполнялось, и полученную сумму дарил мне.
Ответы (1)
2. Составить программу к следующей задаче: "Американский дедушка, подарил своему внуку на 1 день рождения 1$. Каждый следующий день рождения он удваивал свой предыдущий подарок и прибавлял к нему сколько долларов, сколько лет исполнялось внуку.
Ответы (1)
Программа выполняется в Паскале! Составьте программу для решения следующей задачи: Сбербанк начисляет 2% годовых. Вычислите, какой станет сумма вклада S, положенная в сбербанк на N лет. Значения S и N вводятся с клавиатуры. Помогите плииз.
Ответы (1)