Задать вопрос
4 ноября, 03:15

Мой богатый дядюшка подарил мне 1 доллар в мой первый день рождения. В каждый следующий день рождения он удваивал свой подарок и прибавлял к нему столько долларов, сколько лет мне исполнилось. Посчитать общую сумму денег, подаренных к N-ому дню рождения, и указать к какому дню рождения сумма подарки превысит 100 долларов

+2
Ответы (1)
  1. 4 ноября, 05:05
    0
    var y, i, m, n:integer;

    begin;

    readln (n) ;

    m:=1;

    while m<100 do

    begin;

    inc (y) ;

    m:=m*2+y;

    end;

    write (y+1) ;

    m:=0;

    writeln;

    for i:=1 to n do

    begin;

    m:=m*2+i;

    writeln ('y=', i,' m=', m) ;

    end;

    end.

    y=1 m=1

    y=2 m=3

    y=3 m=8

    y=4 m=19

    y=5 m=42

    y=6 m=89

    7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Мой богатый дядюшка подарил мне 1 доллар в мой первый день рождения. В каждый следующий день рождения он удваивал свой подарок и прибавлял ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Мой богатый дядюшка подарил мне один доллар на мой первый день рождения. В каждый следующий день рождения он удваивал свой прошлогодний подарок, прибавлял к нему столько долларов, сколько лет мне исполнялось, и полученную сумму дарил мне.
Ответы (1)
Один богатый дядюшка подарил племяннику 1 доллар в его первый день рождения. В каждый следующий день рождения он удваивал подарок и прибавлял к нему столько долларов, сколько лет исполнялось мальчику.
Ответы (1)
Программа выполняется в Паскале! Составьте программу для решения следующей задачи: Дядюшка подарил своему племяннику на первый день рождения 1 доллар.
Ответы (1)
2. Составить программу к следующей задаче: "Американский дедушка, подарил своему внуку на 1 день рождения 1$. Каждый следующий день рождения он удваивал свой предыдущий подарок и прибавлял к нему сколько долларов, сколько лет исполнялось внуку.
Ответы (1)
Ребят не могу создать прграмму помогите " Солдат хочет купить w бананов в магазине. Ему надо заплатить k долларов за первый банан, 2k долларов - за второй и так далее (иными словами, за i-й банан надо заплатить i·k долларов). У него есть n долларов.
Ответы (1)