Задать вопрос
27 июня, 20:15

Один богатый дядюшка подарил племяннику 1 доллар в его первый день рождения. В каждый следующий день рождения он удваивал подарок и прибавлял к нему столько долларов, сколько лет исполнялось мальчику. Сосчитать, сколько подаренных денег накопиться к 18-летию мальчика

+4
Ответы (1)
  1. 27 июня, 20:38
    0
    Var i, p, s:integer;

    begin

    p:=1; s:=1;

    for i:=2 to 18 do

    begin

    p:=p*2;

    s:=s+p+i;

    end;

    writeln ('s = ', s) ;

    end.

    Результат:

    s = 262313
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Один богатый дядюшка подарил племяннику 1 доллар в его первый день рождения. В каждый следующий день рождения он удваивал подарок и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Мой богатый дядюшка подарил мне один доллар на мой первый день рождения. В каждый следующий день рождения он удваивал свой прошлогодний подарок, прибавлял к нему столько долларов, сколько лет мне исполнялось, и полученную сумму дарил мне.
Ответы (1)
Мой богатый дядюшка подарил мне 1 доллар в мой первый день рождения. В каждый следующий день рождения он удваивал свой подарок и прибавлял к нему столько долларов, сколько лет мне исполнилось.
Ответы (1)
2. Составить программу к следующей задаче: "Американский дедушка, подарил своему внуку на 1 день рождения 1$. Каждый следующий день рождения он удваивал свой предыдущий подарок и прибавлял к нему сколько долларов, сколько лет исполнялось внуку.
Ответы (1)
Программа выполняется в Паскале! Составьте программу для решения следующей задачи: Дядюшка подарил своему племяннику на первый день рождения 1 доллар.
Ответы (1)
Ребят не могу создать прграмму помогите " Солдат хочет купить w бананов в магазине. Ему надо заплатить k долларов за первый банан, 2k долларов - за второй и так далее (иными словами, за i-й банан надо заплатить i·k долларов). У него есть n долларов.
Ответы (1)