Задать вопрос
16 мая, 18:44

Составьте программу из 16 случайных целых чисел от - 20 до 20, и опередяет, есть ли в этом массиве целые числа, равные 0. На экран выводятся исходный массив и индекс последнего найденого элемента

+4
Ответы (1)
  1. 16 мая, 21:29
    0
    Begin

    var k:=-1;

    var a:array[1 ... 16] of integer;

    for var i:=1 to 16 do begin

    a[i]:=20-random (40) + 1;

    print (a[i]) ;

    if a[i]=0 then k:=i;

    end;

    if k-1 then writeln ('Индекс : ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу из 16 случайных целых чисел от - 20 до 20, и опередяет, есть ли в этом массиве целые числа, равные 0. На экран ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
Вычислить сумму и разность двух одномерных массивов содержащих 20 элементов. В массиве суммы найти максимальный элемент и его индекс. В массиве разности найти минимальный элемент и его индекс. Исходные массивы ввести при помощи случайных чисел.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)