Задать вопрос
13 января, 10:08

Даны площадь S1 круга и площадь S2 квадрата определите поместиться ли круг в квадрат. Напишите программу на паскале

+1
Ответы (1)
  1. 13 января, 11:44
    0
    Var s1, s2, r, a:real;

    begin

    read (s1, s2) ;

    r:=sqrt (s1/pi) ;

    a:=sqrt (s2) ;

    if a*sqrt (2) / 2<=r then writeln ('Поместится')

    else writeln ('Не поместится') ;

    end.

    Вроде так, но проверьте на своих тестах
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны площадь S1 круга и площадь S2 квадрата определите поместиться ли круг в квадрат. Напишите программу на паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны радиусы круга и длина стороны квадрата. определить поместиться ли круг в квадрат
Ответы (1)
Составьте программу: По заданной стороне квадрата и радиусу круга выяснить поместится ли квадрат в круг и круг в квадрат?
Ответы (1)
Составить программу в паскале, которая определит, поместится ли квадрат со стороной А в круг радиуса R, или круг в квадрат.
Ответы (1)
Решить задачу на Паскале. Заданы площади круга S1 и квадрата S2. Определить поместится ли круг в квадрате. Задачу решить при а) S1=70, S2=36,74 б) S1=0,86, S2=0,64 Квадрат поместится в круге, если диаметр окружности меньше или равен стороне квадрата.
Ответы (1)
Помогите составить программу в Pascal ABC С клавиатуры вводят названия трех геометрических фигур, например: - ромб - квадрат - круг. Составить программу, которая выводит на экран эти названия, например: "Геометрические фигуры: ромб, квадрат, круг".
Ответы (1)