Задать вопрос
18 июня, 20:15

Составить программу в паскале, которая определит, поместится ли квадрат со стороной А в круг радиуса R, или круг в квадрат.

+4
Ответы (1)
  1. 18 июня, 22:53
    0
    Var a, r: real;

    begin

    write ('a = ') ; read (a) ;

    write ('r = ') ; read (r) ;

    if r > = a/sqrt (2) then writeln ('Квадрат поместится в круг')

    else if r < = a/2 then writeln ('Круг поместится в квадрат')

    else writeln ('Круг и квадрат не поместятся друг в друга')

    end.

    Пояснение:

    Радиус описанной около квадрата окружности равен половине диагонали квадрата. Диагональ квадрата по теореме Пифагора = √ (a² + a²) = a√2, соответственно радиус = a√2/2 = a/√2. Если радиус данной окружности, больше либо равен a/√2, тогда квадрат помещается в круг.

    Радиус вписанной в квадрат окружности равен половине его стороны, т. е a/2. Если радиус данной окружности меньше либо равен, чем a/2, тогда круг вмещается в квадрат.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в паскале, которая определит, поместится ли квадрат со стороной А в круг радиуса R, или круг в квадрат. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить задачу на Паскале. Заданы площади круга S1 и квадрата S2. Определить поместится ли круг в квадрате. Задачу решить при а) S1=70, S2=36,74 б) S1=0,86, S2=0,64 Квадрат поместится в круге, если диаметр окружности меньше или равен стороне квадрата.
Ответы (1)
Помогите составить программу в Pascal ABC С клавиатуры вводят названия трех геометрических фигур, например: - ромб - квадрат - круг. Составить программу, которая выводит на экран эти названия, например: "Геометрические фигуры: ромб, квадрат, круг".
Ответы (1)
Составьте программу: По заданной стороне квадрата и радиусу круга выяснить поместится ли квадрат в круг и круг в квадрат?
Ответы (1)
Поместится ли книга на ГМД ёмкостью 1.44 мб если в книге 540 страниц на одной странице 60 строк в одной строке 65 символов? если вся книга не поместится то сколько страниц поместится?
Ответы (1)
Составьте на Паскале программу, которая определит, является ли целое число N четным двузначным числом.
Ответы (1)