Задать вопрос
2 июля, 02:23

С клавиатуры вводится целое шестизначное число. Необходимо определить, является ли оно "счастливым". ("Счастливыми" называются те числа, у которых сумма перых трёх цифр равна сумме вторых трёх цифр).

+1
Ответы (1)
  1. 2 июля, 04:37
    0
    var

    x:string;

    a1, a2, a3, b1, b2, b3, cd:integer;

    begin

    readln (x) ;

    if length (x) = 6 then

    begin

    val (copy (x, 1,1), a1, cd) ;

    val (copy (x, 2,1), a2, cd) ;

    val (copy (x, 3,1), a3, cd) ;

    val (copy (x, 4,1), b1, cd) ;

    val (copy (x, 5,1), b2, cd) ;

    val (copy (x, 6,1), b3, cd) ;

    if a1+a2+a3 = b1+b2+b3 then

    writeln ('Lucky')

    else

    writeln ('not Lucky') ;

    end;

    read;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится целое шестизначное число. Необходимо определить, является ли оно "счастливым". ("Счастливыми" называются те числа, у ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Дано четырехзначное число. Проверить, является ли оно "счастливым билетом". Примечание: счастливым билетом называется число, в котором: а) при четном количестве цифр в числе сумма цифр его левой половины равна сумме цифр его правой половины;
Ответы (1)
С клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестс клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестии
Ответы (1)