Задать вопрос
11 октября, 12:54

Задана последовательность из n вещественных чисел. Опреде - лить количество чисел, больших своих соседей, т. е. предыдущего и последующего числа.

+5
Ответы (1)
  1. 11 октября, 16:17
    0
    Const

    n = 50; / / количество элем массиваvar

    a: array [1 ... n] of integer;

    kol, i: integer; begin

    for i : = 1 to n do

    readln (a[i]) ;

    for i : = 2 to n - 1 do

    if (a[i] > a[i + 1]) and (a[i] > a[i - 1]) then

    kol : = kol + 1;

    writeln (kol) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задана последовательность из n вещественных чисел. Опреде - лить количество чисел, больших своих соседей, т. е. предыдущего и последующего ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)
Задан массив, состоящий из 15 элементов вещественного типа. Опреде- лить количество элементов, значения которых больше первого элемента
Ответы (1)
Задана последовательность из n вещественных чисел. Определить количество четных и количество нечетных элементов последовательности. оператор цикла с параметром;
Ответы (2)
Задана последовательность из n вещественных чисел. Определить сумму и количество элементов последовательности, меньших заданного значения d. Задание: Средствами языка Pascal напишите программу для решения поставленной задачи.
Ответы (1)