Задать вопрос
3 февраля, 10:08

Задана последовательность из n вещественных чисел. Определить сумму и количество элементов последовательности, меньших заданного значения d. Задание: Средствами языка Pascal напишите программу для решения поставленной задачи.

+2
Ответы (1)
  1. 3 февраля, 11:22
    0
    Program zadacha;

    Const n = 10;

    Type mas=array[1 ... n] of integer;

    Var s, i, k, d:integer;

    m:mas;

    Begin

    s:=0;

    k:=0;

    readln (d) ;

    For i:=1 to n do

    read (m[i]) ;

    For i:=1 to n do

    if m[i]
    s:=s+m[i];

    k:=k+1;

    end;

    writeln ('Сумма чисел < d = ', s,' Колиество чисел < d = ', k) ;

    end. (Это решение для случая если вы вводите сразу весь массив чисел)

    Program zadacha;

    Const n = 10;

    Var s, i, k, d, m:integer;

    Begin

    s:=0;

    k:=0;

    readln (d) ;

    for i:=1 to n do begin

    readln (m) ;

    if (m < d) then begin

    s:=s+m14;

    k:=k+1;

    end;

    end;

    writeln ('Сумма чисел < d = ', s,' Колиество чисел < d = ', k) ;

    end. (А это решение для того случая когда вы вводите элементы по одному)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задана последовательность из n вещественных чисел. Определить сумму и количество элементов последовательности, меньших заданного значения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)