Задать вопрос
15 июня, 18:22

Задана последовательность из n вещественных чисел. Определить

количество четных и количество нечетных элементов

последовательности.

оператор цикла с параметром;

+1
Ответы (2)
  1. 15 июня, 20:35
    0
    Ну вот тебе внутренняя часть проги:k:=0;

    while k<=n do beginif x mod 2=0 then a:=a+1 else s:=s+1k:=k+1end; writeln ('Кол-во четных = ', a, ' Кол-во нечетных = ', s)
  2. 15 июня, 21:26
    0
    Program p;

    var n, a, k, m, i:integer;

    begin

    writeln ('Введите n') ;

    write ('n=') ;

    readln (n) ;

    k:=0;

    m:=0;

    for i:=1 to n do begin

    readln (a) ;

    if a mod 2=0 then k:=k+1

    else m:=m+1;

    end;

    writeln ('Количество четных ', k) ;

    writeln ('Количество нечетных ', m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задана последовательность из n вещественных чисел. Определить количество четных и количество нечетных элементов последовательности. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Соотнесите названия операторов, служебных слов, функций и их написание на языке Paskal: 1. Оператор ввода данных a) Begin, End 2. Условный оператор в неполной форме b) Sqrt (X) 3. Оператор цикла с предусловием c) N div M 4.
Ответы (1)
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)