Задать вопрос
18 апреля, 22:39

Заполнить квадратный двумерный массив таким образом, чтобы по диагонали были расположены 0, под диагональю 1, над диагональю элементы были равны сумме своих индексов. Pascal ABC

+2
Ответы (2)
  1. 19 апреля, 01:37
    0
    Program z;

    Type mas=array [1 ... 100,1 ... 100] of integer;

    Var i, j, nx:integer;

    a:mas;

    Begin

    read (nx) ;

    For i:=1 to nx do

    For j:=1 to nx do

    Begin

    If i>j then

    a[i, j]:=1;

    If i
    a[i, j]:=i+j;

    If i=j then

    a[i, j]:=0;

    end;

    For i:=1 to nx do

    begin;

    For j:=1 to nx do

    write ([a[i, j]],' ') ;

    writeln;

    end;

    End.
  2. 19 апреля, 02:21
    0
    Const

    nmax=100;

    var

    a:array[1 ... nmax, 1 ... nmax] of byte;

    i, j, n:integer;

    begin

    Write ('Сколько в массиве строк или столбцов? ') ;

    Readln (n) ;

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    if i
    else if i=j then a[i, j]:=0

    else a[i, j]:=1;

    Write (a[i, j]:4)

    end;

    Writeln

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполнить квадратный двумерный массив таким образом, чтобы по диагонали были расположены 0, под диагональю 1, над диагональю элементы были ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна содержаться сумма индексов.
Ответы (1)
Напишите программу, которая сортирует одномерный массив. Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна
Ответы (1)
1) Требуется создать двумерный массив целых чисел размером MxN, где M и N вводятся пользователем, но не превышают 15. Заполнить массив числами равными сумме индексов элемента (например элемент[3,4] : = 7). Полученные значения заносить во множество.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
Паскаль! Заполнить двумерный массив N x N случайными числами из интервала [-10; 10], выяснить что больше сумма элементов лежащих над главной диагональю или под главной диагональю.
Ответы (1)