Задать вопрос
18 апреля, 22:28

Написать программу, которая считает, сколько раз последовательности из 10 чисел встречается введённое с клавиатуры число А.

+4
Ответы (1)
  1. 19 апреля, 01:49
    0
    Var i, k, n: integer;

    a: array[1 ... 10] of integer;

    begin

    k:=0; randomize;

    writeln ('число: ') ; readln (n) ;

    writeln ('последовательность из 10 элементов') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (50) ;

    write (a[i],' ') ;

    if a[i]=n then k:=k+1;

    end;

    writeln;

    if k>0 then

    writeln ('число ', n,' встречается ', k,' раз')

    else

    writeln ('числа ', n,' нет в последовательности') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая считает, сколько раз последовательности из 10 чисел встречается введённое с клавиатуры число А. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Проверка условия и ветвление в алгоритме. Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран: а) удвоенное значение числа, если число положительное; б) абсолютное значение числа, если число отрицательное.
Ответы (1)
Помогите написать программы ... Задача 1 Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры Задача 2 Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран Задача 3
Ответы (1)
Если целое число М, введенное с клавиатуры, делится на целое число Н, введенное с клавиатуры, с остатком равным 2, то вывести на экран целую часть от деления М на Н, в противном случае - сообщение "при делении ... на ... остаток не равен 2"
Ответы (1)
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)