Задать вопрос
11 мая, 03:46

Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна содержаться сумма индексов.

+5
Ответы (1)
  1. 11 мая, 05:29
    0
    Const

    M = 4;

    N = 4;

    Var

    A:array[1 ... M, 1 ... N] of integer;

    i, j:integer;

    Begin

    WriteLn ('Массив:') ;

    For i: = 1 to M do

    Begin

    For j: = 1 to N do

    Begin

    if (i+j) mod 2 = 0 then A[i, j]:=i*j

    else A[i, j]:=i+j;

    Write (A[i, j]:3,' ')

    End;

    WriteLn

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая сортирует одномерный массив. Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна
Ответы (1)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Составьте алгоритм вычисления суммы целых чисел x, y, z. Определить четная ли она, если четная, то найти среднее арифметическое значение данных чисел, если нечетная, то найти их среднее геометрическое значение.
Ответы (1)
КАК здесь определяется сумма разрядов? Произведём обработку каждого слова принятого сообщения. Первое слово: 1101001, сумма его разрядов 4 - чётная, слово не изменяется. Второе слово: 0001001, сумма его разрядов 2 - чётная, слово не изменяется.
Ответы (2)