Задать вопрос
2 сентября, 17:56

Составьте алгоритм вычисления суммы целых чисел x, y, z. Определить

четная ли она, если четная, то найти среднее арифметическое значение

данных чисел, если нечетная, то найти их среднее геометрическое значение.

+1
Ответы (1)
  1. 2 сентября, 20:12
    0
    Var x, y, z, sum: integer;

    var average, geometric: real;

    begin

    sum:=0;

    geometric:=0;

    writeln ('Введите x y z') ;

    readln (x, y, z) ;

    sum:=x + y + z;

    if (sum mod 2 = 0) then

    begin

    average:=sum/3;

    writeln ('Среднее арифметическое равно ', average) ;

    end

    else

    begin

    geometric:=sqrt (x*y*z) ;

    writeln ('Среднее геометрическое равно ', geometric) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте алгоритм вычисления суммы целых чисел x, y, z. Определить четная ли она, если четная, то найти среднее арифметическое значение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Описать процедуру Mean (X, Y, AMean, GMean), вычисляющую среднее арифметическое AMean = (X+Y) / 2 и среднее геометрическое двух положительных чисел X и Y (X и Y - входные, AMean и GMean - выходные параметры вещественного типа).
Ответы (1)
Какой алгоритм называется линейным? А. Алгоритм, в котором имеется ввод данных, вычисления и вывод результатов. Б. Алгоритм, в котором для получения результатов последовательно выполняются все операторы по одному разу В.
Ответы (1)
Функции памяти компьютера-ввод данных, хранение данных, накопление данных, обработка данных. Надо выбрать. Функции процессора: вывод данных, обработка данных, хранение данных, накопление данных. Надо выбрать.
Ответы (1)
Линейные алгоритмы. 1. Даны три действительных положительных числа. Найти среднее геометрическое и среднее арифметическое этих чисел. Условный оператор if. 2. Заданы два числа х, у. Меньшее из двух значений заменить на 0.
Ответы (1)
Напишите программы на Паскале, используя цикл "Пока". 1) Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. 2) Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^N.
Ответы (1)