Задать вопрос
1 мая, 09:41

В программу вводится число она должна преобразовать в другое число в котором цифры располагаются в обратном порядку по сравнению с первым числом

+4
Ответы (1)
  1. 1 мая, 11:25
    0
    Программа на паскале, так как язык не указан

    program chisloNaOborot;

    var a, N: integer;

    begin

    writeln ('Введите число') ;

    readln (N) ;

    a:=0;

    while N>0 do

    begin

    a:=a*10+N mod 10;

    N:=N div 10;

    end;

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В программу вводится число она должна преобразовать в другое число в котором цифры располагаются в обратном порядку по сравнению с первым ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Вводится число. Преобразовать его в другое число, цифры которого будут следовать в обратном порядке
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)