Задать вопрос
1 января, 04:52

3. Определить количество натуральных чисел, сумма которых превысит 100, если суммирование началось с 1 и каждое слагаемое на единицу больше предыдущего

+2
Ответы (1)
  1. 1 января, 05:41
    0
    PascalABC

    var n, s:integer;

    begin

    n:=0;

    s:=0;

    while s<=100 do

    begin

    n:=n+1;

    s:=s+n;

    end;

    writeln ('Количество чисел = ', n,'. Их сумма = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «3. Определить количество натуральных чисел, сумма которых превысит 100, если суммирование началось с 1 и каждое слагаемое на единицу больше ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определить количество натуральных чисел, сумма которых превысит 100, если суммирование началось с 1 и каждое слагаемое на единицу больше предыдущего
Ответы (1)
Организовать суммирование введённых с клавиатуры чисел до тех пор, пока значение суммы не превысит S. Вывести полученную сумму на экран.
Ответы (1)
составить программу суммирования натуральных чисел 1 ... n пока их сумма не превысит величину h. Вывести на экран последнее слагаемое и сумму
Ответы (2)
Петя загадал последовательность из 4 чисел, в которой каждое следующее число на единицу больше предыдущего. После этого он записал каждое число в системе счисления с определенным основанием, не меняя порядка чисел.
Ответы (1)
1) Найдите сумму натуральных нечетных чисел не превышающих n! Это нужно сделать циклом for. 2) Составьте программу, которая производит суммирование произвольного количества целых чисел вводимых с клавиатуры.
Ответы (1)